Framework7 CLI Installation

First of all make sure you have latest stable Node.js and NPM installed on your machine.

If you are going to targer Native/Hybrid apps then you also need to install Cordova first (may require sudo):

$ npm install -g cordova

Now we can install Framework7 CLI (may require sudo):

$ npm install -g framework7-cli

If you have issues with installation related to access errors, you may try to run the command with additional flags:

$ npm install -g framework7-cli --unsafe-perm=true --allow-root

If you don't want to install it globally, it can also be used with npx.